mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
29 lines
969 B
Makefile
29 lines
969 B
Makefile
PORTNAME= django-debug-toolbar
|
|
PORTVERSION= 5.1.0
|
|
CATEGORIES= www python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj50-
|
|
DISTNAME= django_debug_toolbar-${PORTVERSION}
|
|
|
|
MAINTAINER= kai@FreeBSD.org
|
|
COMMENT= Configurable set of panels to display debug information
|
|
WWW= https://github.com/django-commons/django-debug-toolbar
|
|
|
|
LICENSE= BSD3CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
DEPRECATED= Extended support of Django 5.0 ends April 2025, upgrade to the Django 5.1+ version of this port. See https://www.djangoproject.com/download/
|
|
EXPIRATION_DATE=2025-05-31
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django50>=4.2.9:www/py-django50@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}sqlparse>=0.2.0:databases/py-sqlparse@${PY_FLAVOR}
|
|
|
|
USES= python:3.10+
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}*${PORTNAME}
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|