mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
The Google API Client Library enables you to work with Google APIs such as Google+, Drive, or YouTube on your server. These client libraries are officially supported by Google. However, the libraries are considered complete and are in maintenance mode. This means that we will address critical bugs and security issues but will not add any new features. WWW: https://github.com/google/google-api-php-client PR: 227881
28 lines
661 B
Makefile
28 lines
661 B
Makefile
PORTNAME= google-api-php-client
|
|
PORTVERSION= 2.12.4
|
|
DISTVERSIONPREFIX= v
|
|
CATEGORIES= www
|
|
PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= contato@kanazuchi.com
|
|
COMMENT= Google api client for php
|
|
WWW= https://github.com/googleapis/google-api-php-client
|
|
|
|
LICENSE= APACHE20
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PHP_PKGNAMEPREFIX}composer>=0:devel/php-composer@${PHP_FLAVOR}
|
|
|
|
USES= php:flavors
|
|
USE_GITHUB= yes
|
|
GH_ACCOUNT= googleapis
|
|
|
|
NO_ARCH= yes
|
|
NO_BUILD= yes
|
|
|
|
do-install:
|
|
${MKDIR} ${STAGEDIR}${WWWDIR}
|
|
(cd ${WRKSRC} && ${COPYTREE_SHARE} src ${STAGEDIR}${WWWDIR})
|
|
${INSTALL_DATA} ${WRKSRC}/composer.json ${STAGEDIR}${WWWDIR}
|
|
|
|
.include <bsd.port.mk>
|