mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.
23 lines
608 B
Makefile
23 lines
608 B
Makefile
PORTNAME= elasticsearch-model
|
|
PORTVERSION= 7.2.1
|
|
PORTREVISION= 1
|
|
CATEGORIES= textproc rubygems
|
|
MASTER_SITES= RG
|
|
PKGNAMESUFFIX= -gitlab
|
|
|
|
MAINTAINER= mfechner@FreeBSD.org
|
|
COMMENT= ActiveModel/Record integrations for Elasticsearch
|
|
WWW= https://github.com/elastic/elasticsearch-rails/tree/master/elasticsearch-model
|
|
|
|
LICENSE= APACHE20
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
|
|
|
RUN_DEPENDS= rubygem-activesupport70>=3:devel/rubygem-activesupport70 \
|
|
rubygem-elasticsearch-gitlab>=7<8:textproc/rubygem-elasticsearch-gitlab \
|
|
rubygem-hashie>=0:devel/rubygem-hashie
|
|
|
|
USES= gem
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|