ports/textproc/rubygem-elasticsearch-gitlab/Makefile
Matthias Fechner edc8d0390e www/gitlab: fix regression from 335fc7c38d
Gitlab requires net-http 0.4.1:
Because faraday >= 2, < 2.5 could not be found in locally installed gems
  and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems,
  faraday >= 2, < 2.12.1 cannot be used.
And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5,
  faraday >= 2 requires faraday-net_http >= 2.0, < 3.5.
Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0
and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed
gems,
  faraday-net_http >= 2.0 requires net-http >= 0.5.0.
Thus, faraday >= 2 requires net-http >= 0.5.0.
So, because Gemfile depends on faraday ~> 2
  and Gemfile depends on net-http = 0.4.1,
  version solving has failed.

While fixing the problem, moved gitlab used packages to own package names with a
PKGNAMESUFFIX of `-gitlab`.
This should make the gitlab package much more stable if updates in the ports are done.
2024-11-22 15:15:15 +02:00

24 lines
663 B
Makefile

PORTNAME= elasticsearch
PORTVERSION= 7.17.11
CATEGORIES= textproc rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= -gitlab
MAINTAINER= mfechner@FreeBSD.org
COMMENT= Ruby integrations for Elasticsearch
WWW= https://github.com/elastic/elasticsearch-ruby
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-elasticsearch-api-gitlab>=${PORTVERSION}<${PORTVERSION}_99:textproc/rubygem-elasticsearch-api-gitlab \
rubygem-elasticsearch-transport-gitlab>=${PORTVERSION}<${PORTVERSION}_99:textproc/rubygem-elasticsearch-transport-gitlab
USES= gem
NO_ARCH= yes
post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/elastic_ruby_console
.include <bsd.port.mk>