mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
23 lines
647 B
Makefile
23 lines
647 B
Makefile
PORTNAME= linkify-it-py
|
|
PORTVERSION= 2.0.3
|
|
CATEGORIES= textproc python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Links recognition library with FULL unicode support
|
|
WWW= https://github.com/tsutsu3/linkify-it-py
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}uc-micro-py>=0:textproc/py-uc-micro-py@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|