ports/textproc/py-backrefs/Makefile
Kai Knoblich 230ddcbe05 textproc/py-backrefs: New port
Backrefs is a wrapper around Python's built-in Re and the 3rd party
Regex library.

Backrefs adds various additional back references (and a couple other
features) that are known to some regular expression engines, but not to
Python's Re and/or Regex.  The supported back references actually vary
depending on the regular expression engine being used as the engine may
already have support for some.
2025-03-07 14:47:38 +01:00

29 lines
766 B
Makefile

PORTNAME= backrefs
DISTVERSION= 5.8
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= kai@FreeBSD.org
COMMENT= Wrapper around re and regex that adds additional back references
WWW= https://github.com/facelessuser/backrefs
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.1:devel/py-hatchling@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist pep517 pytest
TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
NO_ARCH= yes
OPTIONS_DEFINE= EXTRAS
OPTIONS_DEFAULT= EXTRAS
EXTRAS_DESC= Support for bregex (a wrapper for the external Regex library)
EXTRAS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}regex>0:textproc/py-regex@${PY_FLAVOR}
.include <bsd.port.mk>