mirror of
https://git.freebsd.org/ports.git
synced 2025-05-06 19:06:44 -04:00
27 lines
639 B
Makefile
27 lines
639 B
Makefile
PORTNAME= cpp-peglib
|
|
DISTVERSIONPREFIX= v
|
|
DISTVERSION= 1.9.1
|
|
CATEGORIES= textproc devel
|
|
|
|
MAINTAINER= yuri@FreeBSD.org
|
|
COMMENT= C++ header-only PEG (Parsing Expression Grammars) library
|
|
WWW= https://github.com/yhirose/cpp-peglib
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
TEST_DEPENDS= googletest>0:devel/googletest
|
|
|
|
USES= cmake:testing compiler:c++17-lang localbase:ldflags
|
|
|
|
USE_GITHUB= yes
|
|
GH_ACCOUNT= yhirose
|
|
|
|
CMAKE_OFF= BUILD_TESTS
|
|
CMAKE_TESTING_ON= BUILD_TESTS # tests fail to link, see https://github.com/yhirose/cpp-peglib/issues/281#issuecomment-1869064489
|
|
|
|
NO_ARCH= yes
|
|
|
|
PLIST_FILES= include/peglib.h
|
|
|
|
.include <bsd.port.mk>
|