ports/sysutils/py-python-consul/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

30 lines
857 B
Makefile

PORTNAME= python-consul
PORTVERSION= 1.1.0
DISTVERSIONPREFIX= v
PORTREVISION= 2
CATEGORIES= sysutils python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jhixson@FreeBSD.org
COMMENT= Python client for consul
WWW= https://github.com/cablehead/python-consul
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/bin/consul:sysutils/consul \
${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${PY_FLAVOR}
RUN_DEPENDS= ${LOCALBASE}/bin/consul:sysutils/consul \
${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${PY_FLAVOR}
# 2.7 or 3.6+, but it cannot be expressed right now.
USES= python
USE_PYTHON= distutils autoplist
USE_GITHUB= yes
GH_ACCOUNT= cablehead
.include <bsd.port.mk>