mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
This fixes incorrect flag setting, and several edge case bugs found in old versions and modified systems. Changes: https://bazaar.launchpad.net/~fullermd/freebsd-rustdate/trunk/view/341/CHANGES#L4 PR: 284179
248 lines
5.5 KiB
Text
248 lines
5.5 KiB
Text
CARGO_CRATES= addr2line-0.24.2 \
|
|
adler2-2.0.0 \
|
|
android-tzdata-0.1.1 \
|
|
android_system_properties-0.1.5 \
|
|
anstream-0.6.18 \
|
|
anstyle-1.0.10 \
|
|
anstyle-parse-0.2.6 \
|
|
anstyle-query-1.1.2 \
|
|
anstyle-wincon-3.0.7 \
|
|
anyhow-1.0.95 \
|
|
async-trait-0.1.85 \
|
|
autocfg-1.4.0 \
|
|
backtrace-0.3.74 \
|
|
base16ct-0.2.0 \
|
|
base64-0.22.1 \
|
|
bitflags-2.8.0 \
|
|
block-buffer-0.10.4 \
|
|
bumpalo-3.16.0 \
|
|
byteorder-1.5.0 \
|
|
bytes-1.9.0 \
|
|
bzip2-0.4.4 \
|
|
bzip2-sys-0.1.11+1.0.8 \
|
|
cc-1.2.10 \
|
|
cdivsufsort-2.0.0 \
|
|
cfg-if-1.0.0 \
|
|
chrono-0.4.39 \
|
|
clap-4.5.26 \
|
|
clap_builder-4.5.26 \
|
|
clap_complete-4.5.42 \
|
|
clap_derive-4.5.24 \
|
|
clap_lex-0.7.4 \
|
|
colorchoice-1.0.3 \
|
|
console-0.15.10 \
|
|
core-foundation-sys-0.8.7 \
|
|
cpufeatures-0.2.16 \
|
|
crc32fast-1.4.2 \
|
|
crossbeam-0.8.4 \
|
|
crossbeam-channel-0.5.14 \
|
|
crossbeam-deque-0.8.6 \
|
|
crossbeam-epoch-0.9.18 \
|
|
crossbeam-queue-0.3.12 \
|
|
crossbeam-utils-0.8.21 \
|
|
crypto-common-0.1.6 \
|
|
darling-0.20.10 \
|
|
darling_core-0.20.10 \
|
|
darling_macro-0.20.10 \
|
|
data-encoding-2.7.0 \
|
|
deranged-0.3.11 \
|
|
diffy-0.4.0 \
|
|
digest-0.10.7 \
|
|
displaydoc-0.2.5 \
|
|
edit-0.1.5 \
|
|
educe-0.6.0 \
|
|
either-1.13.0 \
|
|
encode_unicode-1.0.0 \
|
|
enum-as-inner-0.6.1 \
|
|
enum-ordinalize-4.3.0 \
|
|
enum-ordinalize-derive-4.3.1 \
|
|
equivalent-1.0.1 \
|
|
errno-0.3.10 \
|
|
fastrand-2.3.0 \
|
|
flate2-1.0.35 \
|
|
fnv-1.0.7 \
|
|
foreign-types-0.3.2 \
|
|
foreign-types-shared-0.1.1 \
|
|
form_urlencoded-1.2.1 \
|
|
futures-channel-0.3.31 \
|
|
futures-core-0.3.31 \
|
|
futures-io-0.3.31 \
|
|
futures-task-0.3.31 \
|
|
futures-util-0.3.31 \
|
|
generic-array-0.14.7 \
|
|
getrandom-0.2.15 \
|
|
gimli-0.31.1 \
|
|
hashbrown-0.12.3 \
|
|
hashbrown-0.15.2 \
|
|
heck-0.5.0 \
|
|
hex-0.4.3 \
|
|
hickory-proto-0.24.2 \
|
|
hickory-resolver-0.24.2 \
|
|
home-0.5.11 \
|
|
hostname-0.3.1 \
|
|
hostname-0.4.0 \
|
|
iana-time-zone-0.1.61 \
|
|
iana-time-zone-haiku-0.1.2 \
|
|
icu_collections-1.5.0 \
|
|
icu_locid-1.5.0 \
|
|
icu_locid_transform-1.5.0 \
|
|
icu_locid_transform_data-1.5.0 \
|
|
icu_normalizer-1.5.0 \
|
|
icu_normalizer_data-1.5.0 \
|
|
icu_properties-1.5.1 \
|
|
icu_properties_data-1.5.0 \
|
|
icu_provider-1.5.0 \
|
|
icu_provider_macros-1.5.0 \
|
|
ident_case-1.0.1 \
|
|
idna-1.0.3 \
|
|
idna_adapter-1.2.0 \
|
|
indexmap-1.9.3 \
|
|
indexmap-2.7.1 \
|
|
indicatif-0.17.9 \
|
|
ipconfig-0.3.2 \
|
|
ipnet-2.11.0 \
|
|
is_terminal_polyfill-1.70.1 \
|
|
itertools-0.14.0 \
|
|
itoa-1.0.14 \
|
|
js-sys-0.3.77 \
|
|
libc-0.2.169 \
|
|
linked-hash-map-0.5.6 \
|
|
linux-raw-sys-0.4.15 \
|
|
litemap-0.7.4 \
|
|
lock_api-0.4.12 \
|
|
log-0.4.25 \
|
|
lru-cache-0.1.2 \
|
|
match_cfg-0.1.0 \
|
|
memchr-2.7.4 \
|
|
miniz_oxide-0.8.3 \
|
|
mio-1.0.3 \
|
|
nu-ansi-term-0.50.1 \
|
|
num-conv-0.1.0 \
|
|
num-traits-0.2.19 \
|
|
number_prefix-0.4.0 \
|
|
object-0.36.7 \
|
|
once_cell-1.20.2 \
|
|
openssl-0.10.68 \
|
|
openssl-macros-0.1.1 \
|
|
openssl-sys-0.9.104 \
|
|
parking_lot-0.12.3 \
|
|
parking_lot_core-0.9.10 \
|
|
percent-encoding-2.3.1 \
|
|
pin-project-lite-0.2.16 \
|
|
pin-utils-0.1.0 \
|
|
pkg-config-0.3.31 \
|
|
portable-atomic-1.10.0 \
|
|
powerfmt-0.2.0 \
|
|
ppv-lite86-0.2.20 \
|
|
proc-macro2-1.0.93 \
|
|
qbsdiff-1.4.2 \
|
|
quick-error-1.2.3 \
|
|
quote-1.0.38 \
|
|
rand-0.8.5 \
|
|
rand_chacha-0.3.1 \
|
|
rand_core-0.6.4 \
|
|
rand_pcg-0.3.1 \
|
|
rayon-1.10.0 \
|
|
rayon-core-1.12.1 \
|
|
redox_syscall-0.5.8 \
|
|
regex-lite-0.1.6 \
|
|
resolv-conf-0.7.0 \
|
|
rustc-demangle-0.1.24 \
|
|
rustix-0.38.43 \
|
|
rustversion-1.0.19 \
|
|
ryu-1.0.18 \
|
|
sacabase-2.0.0 \
|
|
same-file-1.0.6 \
|
|
scopeguard-1.2.0 \
|
|
serde-1.0.217 \
|
|
serde_derive-1.0.217 \
|
|
serde_json-1.0.137 \
|
|
serde_with-3.12.0 \
|
|
serde_with_macros-3.12.0 \
|
|
sha2-0.10.8 \
|
|
shlex-1.3.0 \
|
|
slab-0.4.9 \
|
|
smallvec-1.13.2 \
|
|
socket2-0.5.8 \
|
|
stable_deref_trait-1.2.0 \
|
|
strsim-0.11.1 \
|
|
strum-0.26.3 \
|
|
strum_macros-0.26.4 \
|
|
suffix_array-0.5.0 \
|
|
syn-2.0.96 \
|
|
synstructure-0.13.1 \
|
|
sysctl-0.6.0 \
|
|
tempfile-3.15.0 \
|
|
terminal_size-0.4.1 \
|
|
thiserror-1.0.69 \
|
|
thiserror-2.0.11 \
|
|
thiserror-impl-1.0.69 \
|
|
thiserror-impl-2.0.11 \
|
|
time-0.3.37 \
|
|
time-core-0.1.2 \
|
|
time-macros-0.2.19 \
|
|
tinystr-0.7.6 \
|
|
tinyvec-1.8.1 \
|
|
tinyvec_macros-0.1.1 \
|
|
tokio-1.43.0 \
|
|
tracing-0.1.41 \
|
|
tracing-attributes-0.1.28 \
|
|
tracing-core-0.1.33 \
|
|
typenum-1.17.0 \
|
|
unicode-ident-1.0.14 \
|
|
unicode-width-0.2.0 \
|
|
ureq-2.12.1 \
|
|
url-2.5.4 \
|
|
utf16_iter-1.0.5 \
|
|
utf8_iter-1.0.4 \
|
|
utf8parse-0.2.2 \
|
|
uzers-0.12.1 \
|
|
vcpkg-0.2.15 \
|
|
version_check-0.9.5 \
|
|
walkdir-2.5.0 \
|
|
wasi-0.11.0+wasi-snapshot-preview1 \
|
|
wasm-bindgen-0.2.100 \
|
|
wasm-bindgen-backend-0.2.100 \
|
|
wasm-bindgen-macro-0.2.100 \
|
|
wasm-bindgen-macro-support-0.2.100 \
|
|
wasm-bindgen-shared-0.2.100 \
|
|
web-time-1.1.0 \
|
|
which-4.4.2 \
|
|
widestring-1.1.0 \
|
|
winapi-0.3.9 \
|
|
winapi-i686-pc-windows-gnu-0.4.0 \
|
|
winapi-util-0.1.9 \
|
|
winapi-x86_64-pc-windows-gnu-0.4.0 \
|
|
windows-0.52.0 \
|
|
windows-core-0.52.0 \
|
|
windows-sys-0.48.0 \
|
|
windows-sys-0.52.0 \
|
|
windows-sys-0.59.0 \
|
|
windows-targets-0.48.5 \
|
|
windows-targets-0.52.6 \
|
|
windows_aarch64_gnullvm-0.48.5 \
|
|
windows_aarch64_gnullvm-0.52.6 \
|
|
windows_aarch64_msvc-0.48.5 \
|
|
windows_aarch64_msvc-0.52.6 \
|
|
windows_i686_gnu-0.48.5 \
|
|
windows_i686_gnu-0.52.6 \
|
|
windows_i686_gnullvm-0.52.6 \
|
|
windows_i686_msvc-0.48.5 \
|
|
windows_i686_msvc-0.52.6 \
|
|
windows_x86_64_gnu-0.48.5 \
|
|
windows_x86_64_gnu-0.52.6 \
|
|
windows_x86_64_gnullvm-0.48.5 \
|
|
windows_x86_64_gnullvm-0.52.6 \
|
|
windows_x86_64_msvc-0.48.5 \
|
|
windows_x86_64_msvc-0.52.6 \
|
|
winreg-0.50.0 \
|
|
write16-1.0.0 \
|
|
writeable-0.5.5 \
|
|
yoke-0.7.5 \
|
|
yoke-derive-0.7.5 \
|
|
zerocopy-0.7.35 \
|
|
zerocopy-derive-0.7.35 \
|
|
zerofrom-0.1.5 \
|
|
zerofrom-derive-0.1.5 \
|
|
zerovec-0.10.4 \
|
|
zerovec-derive-0.10.3
|