mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
- Bump PORTREVISION for package change - Bump PORTREVISION of dependent ports for shlib change
39 lines
932 B
Makefile
39 lines
932 B
Makefile
PORTNAME= fileschanged
|
|
PORTVERSION= 0.6.5
|
|
PORTREVISION= 4
|
|
CATEGORIES= sysutils
|
|
MASTER_SITES= SF
|
|
|
|
MAINTAINER= ports@FreeBSD.org
|
|
COMMENT= Utility that reports when files have been altered
|
|
WWW= https://fileschanged.sourceforge.net/
|
|
|
|
LIB_DEPENDS= libargp.so:devel/argp-standalone
|
|
BUILD_DEPENDS= help2man:misc/help2man
|
|
|
|
LICENSE= GPLv2
|
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
|
|
|
GNU_CONFIGURE= yes
|
|
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
|
USES= fam gmake localbase
|
|
CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc --disable-nls
|
|
|
|
LIBS+= -largp
|
|
|
|
INFO= fileschanged
|
|
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README
|
|
PLIST_FILES= bin/fileschanged share/man/man1/fileschanged.1.gz
|
|
|
|
OPTIONS_DEFINE= DOCS
|
|
|
|
post-patch:
|
|
@${REINPLACE_CMD} -e 's| -Werror||' ${WRKSRC}/src/Makefile.in
|
|
|
|
post-install-DOCS-on:
|
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
|
.for DOCFILE in ${PORTDOCS}
|
|
${INSTALL_DATA} ${WRKSRC}/${DOCFILE} ${STAGEDIR}${DOCSDIR}
|
|
.endfor
|
|
|
|
.include <bsd.port.mk>
|