mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
Python implementation of Metasploit's pattern generator and search. Should be python version agnostic, tested and working with Python 2.7.12 up to and including Python 3.11.1 Starts faster and rolls both tools into one. No extra dependencies required, works with vanilla python https://github.com/Svenito/exploit-pattern PR: 280341
27 lines
551 B
Makefile
27 lines
551 B
Makefile
PORTNAME= exploit-pattern
|
|
DISTVERSION= g20230527
|
|
CATEGORIES= security
|
|
|
|
MAINTAINER= tiago.gasiba@gmail.com
|
|
COMMENT= Generate and search pattern string for exploit development
|
|
WWW= https://github.com/${GH_ACCOUNT}/${PORTNAME}
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
|
|
|
USES= python:run shebangfix
|
|
USE_GITHUB= yes
|
|
GH_ACCOUNT= Svenito
|
|
GH_TAGNAME= 59bb0c5
|
|
|
|
SHEBANG_FILES= pattern.py
|
|
|
|
NO_ARCH= yes
|
|
NO_BUILD= yes
|
|
|
|
PLIST_FILES= bin/pattern
|
|
|
|
do-install:
|
|
${INSTALL_SCRIPT} ${WRKSRC}/pattern.py ${STAGEDIR}${PREFIX}/bin/pattern
|
|
|
|
.include <bsd.port.mk>
|