mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
23 lines
574 B
Makefile
23 lines
574 B
Makefile
PORTNAME= python-twitter
|
|
PORTVERSION= 3.5
|
|
PORTREVISION= 1
|
|
CATEGORIES= net python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= python@FreeBSD.org
|
|
COMMENT= Python wrapper around the Twitter API
|
|
WWW= https://github.com/bear/python-twitter
|
|
|
|
LICENSE= APACHE20
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0:www/py-requests-oauthlib@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|