mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
25 lines
582 B
Makefile
25 lines
582 B
Makefile
PORTNAME= nnpy
|
|
DISTVERSION= 1.4.2
|
|
PORTREVISION= 1
|
|
CATEGORIES= net python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= ports@FreeBSD.org
|
|
COMMENT= Python bindings for nanomsg (cffi-based)
|
|
WWW= https://github.com/nanomsg/nnpy
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
LIB_DEPENDS= libnanomsg.so:net/nanomsg
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR}
|
|
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist distutils
|
|
|
|
post-install:
|
|
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_nnpy*.so
|
|
|
|
.include <bsd.port.mk>
|