ports/net/cpp-pcp-client/Makefile
Romain Tartière 0d961a157f
sysutils/rubygem-choria-mcorpc-support: Provide execution_wrapper(1) with choria, deprecate broken ports
The latest boost update broke some components used to run bolt tasks
through choria.  Since these components are legacy ones and have been
archived by their owner, we provide a compatible wrapper directly with
choria, and as these ports are only soft-dependencies for choria and are
broken, we deprecate and set an expiration date on the.

With hat:	puppet
2025-03-08 16:43:52 -10:00

29 lines
663 B
Makefile

PORTNAME= cpp-pcp-client
PORTVERSION= 1.7.7
PORTREVISION= 8
CATEGORIES= net
MAINTAINER= puppet@FreeBSD.org
COMMENT= Client libraries for the PCP protocol
WWW= https://github.com/puppetlabs/cpp-pcp-client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= fails to build with Boost>=1.87
DEPRECATED= Project got archived, broken
EXPIRATION_DATE=2025-05-08
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libleatherman_json_container.so:devel/leatherman
USES= cmake compiler:c++11-lang ssl
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= puppetlabs
CMAKE_OFF= ENABLE_CXX_WERROR
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.include <bsd.port.mk>