mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
25 lines
592 B
Makefile
25 lines
592 B
Makefile
PORTNAME= sympy
|
|
PORTVERSION= 1.13.3
|
|
PORTREVISION= 1
|
|
CATEGORIES= math python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= wen@FreeBSD.org
|
|
COMMENT= Python Library For Symbolic Mathematics
|
|
WWW= https://sympy.org/
|
|
|
|
LICENSE= BSD3CLAUSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpmath>=1.1.0:math/py-mpmath@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= distutils concurrent autoplist pytest
|
|
NO_ARCH= yes
|
|
|
|
OPTIONS_DEFINE= PYGLET
|
|
PYGLET_DESC= Enable plotting support
|
|
|
|
PYGLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet1>=1.1.2:graphics/py-pyglet1@${PY_FLAVOR}
|
|
|
|
.include <bsd.port.mk>
|