ports/math/py-sympy/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

25 lines
592 B
Makefile

PORTNAME= sympy
PORTVERSION= 1.13.3
PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python Library For Symbolic Mathematics
WWW= https://sympy.org/
LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpmath>=1.1.0:math/py-mpmath@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils concurrent autoplist pytest
NO_ARCH= yes
OPTIONS_DEFINE= PYGLET
PYGLET_DESC= Enable plotting support
PYGLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet1>=1.1.2:graphics/py-pyglet1@${PY_FLAVOR}
.include <bsd.port.mk>