ports/math/py-python-fcl/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

29 lines
669 B
Makefile

PORTNAME= python-fcl
PORTVERSION= 0.0.12
PORTREVISION= 4
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= db@FreeBSD.org
COMMENT= Python bindings for the Flexible Collision Library
WWW= https://libraries.io/pypi/python-fcl
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libfcl05.so:math/fcl05 \
liboctomap.so:math/octomap
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
USES= compiler:c++11-lang eigen:3 python
USE_PYTHON= distutils autoplist concurrent cython
PYDISTUTILS_BUILD_TARGET= build_ext
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/fcl/fcl*.so
.include <bsd.port.mk>