ports/math/py-pysmt/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

27 lines
661 B
Makefile

PORTNAME= pysmt
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.6
PORTREVISION= 1
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= 0mp@FreeBSD.org
COMMENT= Solver-agnostic library for SMT formulae manipulation and solving
WWW= http://www.pysmt.org
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}z3-solver>0:math/py-z3-solver@${PY_FLAVOR} \
z3>0:math/z3 \
cvc5>0:math/cvc5
USES= python
USE_GITHUB= yes
USE_PYTHON= distutils autoplist concurrent distutils pytest
PYDISTUTILS_PKGNAME= PySMT
NO_ARCH= yes
.include <bsd.port.mk>