ports/math/py-py-find-1st/Makefile
Yuri Victorovich 2d9517cb83 math/py-py-find-1st: update 1.1.5 → 1.1.6
Reported by:	portscout
2023-10-29 02:03:13 -07:00

27 lines
783 B
Makefile

PORTNAME= py-find-1st
DISTVERSION= 1.1.6
CATEGORIES= math
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/-/_/g}-${PORTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Numpy extension module for efficient search in numpy arrays
WWW= https://github.com/roebel/py_find_1st
LICENSE= GPLv3
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
USES= python
USE_PYTHON= pep517 autoplist pytest # tests are broken, see https://github.com/roebel/py_find_1st/issues/13
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/utils_find_1st/find_1st${PYTHON_EXT_SUFFIX}.so
.include <bsd.port.mk>