ports/math/py-numpy-stl/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

26 lines
619 B
Makefile

PORTNAME= numpy-stl
DISTVERSION= 2.11.3
PORTREVISION= 2
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= db@FreeBSD.org
COMMENT= Simple library to make working with STL files fast and easy
WWW= https://github.com/WoLpH/numpy-stl
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}python-utils>=2.3.0:misc/py-python-utils@${PY_FLAVOR}
USES= python
USE_PYTHON= cython distutils autoplist
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/stl/_speedups*.so
.include <bsd.port.mk>