mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
25 lines
481 B
Makefile
25 lines
481 B
Makefile
PORTNAME= exprtk
|
|
DISTVERSION= 0.0.3
|
|
CATEGORIES= math
|
|
|
|
MAINTAINER= yuri@FreeBSD.org
|
|
COMMENT= C++ Mathematical Expression Toolkit Library
|
|
WWW= https://www.partow.net/programming/exprtk/index.html
|
|
|
|
LICENSE= MIT
|
|
|
|
USE_GITHUB= yes
|
|
GH_ACCOUNT= ArashPartow
|
|
|
|
NO_BUILD= yes
|
|
NO_ARCH= yes
|
|
|
|
PLIST_FILES= include/exprtk.hpp
|
|
|
|
do-install:
|
|
${INSTALL_DATA} ${WRKSRC}/exprtk.hpp ${STAGEDIR}${PREFIX}/include
|
|
|
|
benchmark:
|
|
cd ${WRKSRC} && ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} pgo
|
|
|
|
.include <bsd.port.mk>
|