ports/mail/pizauth/Makefile.crates
Nicola Vitale 4dd578f027
mail/pizauth: Add new port
pizauth is a simple program for requesting, showing, and refreshing OAuth2
access tokens. pizauth is formed of two components: a persistent server which
interacts with the user to request tokens, and refreshes them as necessary; and
a command-line interface which can be used by programs such as fdm, neomutt, or
msmtp to authenticate with OAuth2.

https://tratt.net/laurie/src/pizauth/
2024-09-15 18:14:07 +02:00

154 lines
3.3 KiB
Text

CARGO_CRATES= adler-1.0.2 \
aead-0.5.2 \
aho-corasick-1.1.3 \
android-tzdata-0.1.1 \
android_system_properties-0.1.5 \
anyhow-1.0.86 \
autocfg-1.3.0 \
base64-0.22.1 \
bincode-1.3.3 \
bitflags-1.3.2 \
bitflags-2.5.0 \
block-buffer-0.10.4 \
bstr-1.9.1 \
bumpalo-3.16.0 \
cactus-1.0.7 \
cc-1.0.98 \
cfg-if-1.0.0 \
cfg_aliases-0.2.1 \
cfgrammar-0.13.5 \
chacha20-0.9.1 \
chacha20poly1305-0.10.1 \
chrono-0.4.38 \
cipher-0.4.4 \
core-foundation-sys-0.8.6 \
cpufeatures-0.2.12 \
crc32fast-1.4.2 \
crossbeam-deque-0.8.5 \
crossbeam-epoch-0.9.18 \
crossbeam-utils-0.8.20 \
crypto-common-0.1.6 \
deranged-0.3.11 \
digest-0.10.7 \
equivalent-1.0.1 \
error-chain-0.12.4 \
filetime-0.2.23 \
flate2-1.0.30 \
fnv-1.0.7 \
form_urlencoded-1.2.1 \
generic-array-0.14.7 \
getopts-0.2.21 \
getrandom-0.2.15 \
globset-0.4.14 \
hashbrown-0.14.5 \
hermit-abi-0.3.9 \
hostname-0.3.1 \
iana-time-zone-0.1.60 \
iana-time-zone-haiku-0.1.2 \
idna-0.5.0 \
ignore-0.4.22 \
indexmap-2.2.6 \
inout-0.1.3 \
is-terminal-0.4.12 \
itoa-1.0.11 \
js-sys-0.3.69 \
lazy_static-1.4.0 \
libc-0.2.155 \
log-0.4.21 \
lrlex-0.13.5 \
lrpar-0.13.5 \
lrtable-0.13.5 \
match_cfg-0.1.0 \
memchr-2.7.2 \
miniz_oxide-0.7.3 \
nix-0.29.0 \
num-conv-0.1.0 \
num-traits-0.2.19 \
num_threads-0.1.7 \
once_cell-1.19.0 \
opaque-debug-0.3.1 \
packedvec-1.2.4 \
percent-encoding-2.3.1 \
pledge-0.4.2 \
poly1305-0.8.0 \
powerfmt-0.2.0 \
ppv-lite86-0.2.17 \
proc-macro2-1.0.84 \
quote-1.0.36 \
rand-0.8.5 \
rand_chacha-0.3.1 \
rand_core-0.6.4 \
redox_syscall-0.4.1 \
regex-1.10.4 \
regex-automata-0.4.6 \
regex-syntax-0.8.3 \
rerun_except-1.0.0 \
ring-0.17.8 \
rustc_version-0.4.0 \
rustls-0.22.4 \
rustls-pki-types-1.7.0 \
rustls-webpki-0.102.4 \
rustversion-1.0.17 \
ryu-1.0.18 \
same-file-1.0.6 \
semver-1.0.23 \
serde-1.0.203 \
serde_derive-1.0.203 \
serde_json-1.0.117 \
sha2-0.10.8 \
sparsevec-0.2.0 \
spin-0.9.8 \
static_assertions-1.1.0 \
stderrlog-0.6.0 \
subtle-2.5.0 \
syn-2.0.66 \
syslog-6.1.1 \
termcolor-1.1.3 \
thread_local-1.1.8 \
time-0.3.36 \
time-core-0.1.2 \
time-macros-0.2.18 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
typenum-1.17.0 \
unicode-bidi-0.3.15 \
unicode-ident-1.0.12 \
unicode-normalization-0.1.23 \
unicode-width-0.1.12 \
universal-hash-0.5.1 \
untrusted-0.9.0 \
unveil-0.3.2 \
ureq-2.9.7 \
url-2.5.0 \
urlencoding-2.1.3 \
vergen-8.3.1 \
version_check-0.9.4 \
vob-3.0.3 \
wait-timeout-0.2.0 \
walkdir-2.5.0 \
wasi-0.11.0+wasi-snapshot-preview1 \
wasite-0.1.0 \
wasm-bindgen-0.2.92 \
wasm-bindgen-backend-0.2.92 \
wasm-bindgen-macro-0.2.92 \
wasm-bindgen-macro-support-0.2.92 \
wasm-bindgen-shared-0.2.92 \
web-sys-0.3.69 \
webpki-roots-0.26.1 \
whoami-1.5.1 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.8 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
windows-core-0.52.0 \
windows-sys-0.52.0 \
windows-targets-0.52.5 \
windows_aarch64_gnullvm-0.52.5 \
windows_aarch64_msvc-0.52.5 \
windows_i686_gnu-0.52.5 \
windows_i686_gnullvm-0.52.5 \
windows_i686_msvc-0.52.5 \
windows_x86_64_gnu-0.52.5 \
windows_x86_64_gnullvm-0.52.5 \
windows_x86_64_msvc-0.52.5 \
zeroize-1.8.1