mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
The following features have been added or changed: - Instead of USE_JAVA use USES=java. This defaults to USES=java:build,run if NO_BUILD is undefined. Else it defaults to USES=java:run - Instead of USE_ANT=yes use USES=java:ant which also implies USES=java:build - Instead of JAVA_BUILD=yes use USES=java:build. Does not imply run or extract - Instead of JAVA_EXTRACT=yes use USES=java:extract does not imply build or run - Instead of JAVA_RUN=yes use USES=java:run does not imply extract or build - Instead of USE_JAVA=<version> use USES=java and JAVA_VERSION=<version> Approved by: mat (portmgr), glewis Differential Revision: https://reviews.freebsd.org/D48201
35 lines
803 B
Makefile
35 lines
803 B
Makefile
PORTNAME= pydev
|
|
PORTVERSION= 12.0.0
|
|
CATEGORIES= java devel python
|
|
MASTER_SITES= https://github.com/fabioz/Pydev/releases/download/${PORTNAME}_12_0_0/
|
|
PKGNAMEPREFIX= eclipse-
|
|
DISTNAME= PyDev.${PORTVERSION}
|
|
|
|
MAINTAINER= mizhka@FreeBSD.org
|
|
COMMENT= Eclipse plugin for Python and Jython development
|
|
WWW= https://www.pydev.org/
|
|
|
|
LICENSE= EPL
|
|
|
|
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:java/eclipse
|
|
|
|
USES= java python zip
|
|
JAVA_OS= native
|
|
|
|
NO_BUILD= YES
|
|
NO_WRKSUBDIR= YES
|
|
|
|
PLIST_SUB+= PYDEV_VER=12.0.0.202402010911
|
|
|
|
OPTIONS_DEFINE= JYTHON
|
|
|
|
JYTHON_DESC= Use Jython as Python interpreter
|
|
|
|
JYTHON_RUN_DEPENDS= jython:lang/jython
|
|
|
|
PLUGINDIR= share/eclipse/dropins/${PORTNAME}/eclipse
|
|
|
|
do-install:
|
|
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "features plugins" ${STAGEDIR}${PREFIX}/${PLUGINDIR})
|
|
|
|
.include <bsd.port.mk>
|