mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
USES=java:ant does not imply USES=java:run so we need to add the run arg seperately when we are using USES=java:ant. Not all ports require the the argument so it is better to address the ports individually instead of handling it automatically by implying run for ant. Thanks to vvd for carefully going through this. Reported by: vvd Approved by: portmgr (blanket)
48 lines
1.1 KiB
Makefile
48 lines
1.1 KiB
Makefile
PORTNAME= commons-lang
|
|
PORTVERSION= 2.6
|
|
PORTREVISION= 1
|
|
CATEGORIES= java devel
|
|
MASTER_SITES= APACHE_COMMONS_SOURCE
|
|
PKGNAMEPREFIX= apache-
|
|
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
|
|
|
MAINTAINER= ports@FreeBSD.org
|
|
COMMENT= Apache library with helper utilities for the java.lang API
|
|
WWW= https://commons.apache.org/proper/commons-lang/
|
|
|
|
LICENSE= APACHE20
|
|
|
|
USES= java:ant,run
|
|
JAVA_VERSION= 8
|
|
|
|
ALL_TARGET= jar
|
|
NO_ARCH= yes
|
|
|
|
JARFILE= ${PORTNAME}-${PORTVERSION}.jar
|
|
DESTJARFILE= ${PORTNAME}.jar
|
|
PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
|
|
PORTDOCS= *
|
|
|
|
OPTIONS_DEFINE= DOCS
|
|
|
|
.include <bsd.port.pre.mk>
|
|
|
|
.if ${PORT_OPTIONS:MDOCS}
|
|
ALL_TARGET+= javadoc
|
|
.endif
|
|
|
|
JDK_API!= (${FIND} -s ${LOCALBASE}/share/doc/jdk1.? -maxdepth 1 -name api -type d 2>/dev/null || ${ECHO_CMD}) | ${TAIL} -n 1
|
|
|
|
.if ${JDK_API} != ""
|
|
MAKE_ARGS+= -Djdk.javadoc=${JDK_API}
|
|
.endif
|
|
|
|
do-install:
|
|
${INSTALL_DATA} ${WRKSRC}/target/${JARFILE} \
|
|
${STAGEDIR}${JAVAJARDIR}/${DESTJARFILE}
|
|
.if ${PORT_OPTIONS:MDOCS}
|
|
(cd ${WRKSRC}/target/apidocs && ${COPYTREE_SHARE} . \
|
|
${STAGEDIR}${DOCSDIR})
|
|
.endif
|
|
|
|
.include <bsd.port.post.mk>
|