mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
The following features have been added or changed: - Instead of USE_JAVA use USES=java. This defaults to USES=java:build,run if NO_BUILD is undefined. Else it defaults to USES=java:run - Instead of USE_ANT=yes use USES=java:ant which also implies USES=java:build - Instead of JAVA_BUILD=yes use USES=java:build. Does not imply run or extract - Instead of JAVA_EXTRACT=yes use USES=java:extract does not imply build or run - Instead of JAVA_RUN=yes use USES=java:run does not imply extract or build - Instead of USE_JAVA=<version> use USES=java and JAVA_VERSION=<version> Approved by: mat (portmgr), glewis Differential Revision: https://reviews.freebsd.org/D48201
46 lines
1.1 KiB
Makefile
46 lines
1.1 KiB
Makefile
PORTNAME= commons-dbcp
|
|
PORTVERSION= 2.12.0
|
|
CATEGORIES= java databases
|
|
MASTER_SITES= https://archive.apache.org/dist/commons/dbcp/binaries/
|
|
PKGNAMEPREFIX= apache-
|
|
DISTNAME= ${PORTNAME}2-${PORTVERSION}-bin
|
|
|
|
MAINTAINER= ale@FreeBSD.org
|
|
COMMENT= Apache Commons Database Connection Pool
|
|
WWW= https://commons.apache.org/dbcp/
|
|
|
|
LICENSE= APACHE20
|
|
|
|
RUN_DEPENDS= ${JAVALIBDIR}/commons-pool.jar:java/apache-commons-pool
|
|
|
|
USES= java
|
|
JAVA_VERSION= 8
|
|
|
|
OPTIONS_DEFINE= DOCS
|
|
|
|
NO_BUILD= yes
|
|
NO_ARCH= yes
|
|
|
|
WRKSRC= ${WRKDIR}/${PORTNAME}2-${PORTVERSION}
|
|
JARFILE= ${PORTNAME}2-${PORTVERSION}.jar
|
|
DOCFILES= LICENSE.txt \
|
|
NOTICE.txt \
|
|
RELEASE-NOTES.txt
|
|
|
|
PORTDOCS= *
|
|
PLIST_FILES= ${JAVAJARDIR}/${PORTNAME}.jar \
|
|
${JAVAJARDIR}/${JARFILE}
|
|
|
|
.include <bsd.port.options.mk>
|
|
|
|
do-install:
|
|
${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${STAGEDIR}${JAVAJARDIR}
|
|
${LN} -sf ${JARFILE} ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
|
|
.if ${PORT_OPTIONS:MDOCS}
|
|
cd ${WRKSRC} && ${COPYTREE_SHARE} apidocs ${STAGEDIR}${DOCSDIR}
|
|
.for FILE in ${DOCFILES}
|
|
${INSTALL_MAN} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
|
|
.endfor
|
|
.endif
|
|
|
|
.include <bsd.port.mk>
|