ports/filesystems/squashfs-tools-ng/Makefile
Robert Clausecker 6e2da9672f filesystems: add new category for file systems and related utilities
The filesystems category houses file systems and file system utilities.
It is added mainly to turn the sysutils/fusefs-* pseudo-category into
a proper one, but is also useful for the sundry of other file systems
related ports found in the tree.

Ports that seem like they belong there are moved to the new category.
Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are
not moved as they currently don't fetch and don't have TIMESTAMP set
in their distinfo, but that is required to be able to push a rename
of the port by the pre-receive hook.

Approved by:	portmgr (rene)
Reviewed by:	mat
Pull Request:	https://github.com/freebsd/freebsd-ports/pull/302
PR:		281988
2024-11-06 16:17:35 +01:00

43 lines
1.1 KiB
Makefile

PORTNAME= squashfs-tools-ng
PORTVERSION= 1.3.2
CATEGORIES= filesystems sysutils
MASTER_SITES= https://infraroot.at/pub/squashfs/
MAINTAINER= danfe@FreeBSD.org
COMMENT= New set of tools and libraries to work with SquashFS images
WWW= https://infraroot.at/projects/squashfs-tools-ng/
LICENSE= GPLv3+ LGPL3+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING.md
USES= libtool pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
OPTIONS_DEFINE= DOCS LZ4 LZO TOOLS ZSTD
OPTIONS_DEFAULT= LZ4 LZO TOOLS ZSTD
OPTIONS_SUB= yes
TOOLS_DESC= Build the tools, not just the library
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
LZ4_CONFIGURE_OFF= --without-lz4
LZO_LIB_DEPENDS= liblzo2.so:archivers/lzo2
LZO_CONFIGURE_ENV= LZO_CFLAGS="-I${LOCALBASE}/include" \
LZO_LIBS="-L${LOCALBASE}/lib -llzo2"
LZO_CONFIGURE_OFF= --without-lzo
TOOLS_CONFIGURE_OFF= --without-tools
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_CONFIGURE_OFF= --without-zstd
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${WRKSRC}/README.md \
${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>