mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Changes: https://github.com/fsspec/filesystem_spec/blob/master/docs/source/changelog.rst https://filesystem-spec.readthedocs.io/en/latest/changelog.html
28 lines
747 B
Makefile
28 lines
747 B
Makefile
PORTNAME= fsspec
|
|
PORTVERSION= 2025.3.2
|
|
CATEGORIES= filesystems devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= File-system specification
|
|
WWW= https://filesystem-spec.readthedocs.io/en/latest/ \
|
|
https://github.com/fsspec/filesystem_spec
|
|
|
|
LICENSE= BSD3CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-vcs>=0:devel/py-hatch-vcs@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
OPTIONS_DEFINE= GITHUB
|
|
GITHUB_DESC= GitHub file system
|
|
|
|
GITHUB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
|
|
|
|
.include <bsd.port.mk>
|