ports/filesystems/mtpfs/Makefile
Robert Clausecker 6e2da9672f filesystems: add new category for file systems and related utilities
The filesystems category houses file systems and file system utilities.
It is added mainly to turn the sysutils/fusefs-* pseudo-category into
a proper one, but is also useful for the sundry of other file systems
related ports found in the tree.

Ports that seem like they belong there are moved to the new category.
Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are
not moved as they currently don't fetch and don't have TIMESTAMP set
in their distinfo, but that is required to be able to push a rename
of the port by the pre-receive hook.

Approved by:	portmgr (rene)
Reviewed by:	mat
Pull Request:	https://github.com/freebsd/freebsd-ports/pull/302
PR:		281988
2024-11-06 16:17:35 +01:00

34 lines
693 B
Makefile

PORTNAME= mtpfs
PORTVERSION= 1.1
PORTREVISION= 5
CATEGORIES= filesystems sysutils
MAINTAINER= jhixson@FreeBSD.org
COMMENT= MTP device filesystem
WWW= https://www.adebenham.com/mtpfs/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libmtp.so:multimedia/libmtp \
libid3.so:audio/id3lib \
libid3tag.so:audio/libid3tag \
libmad.so:audio/libmad
USES= autoreconf fuse gnome pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= cjd
GH_TAGNAME= fd3864dd6f0e8183fa2598d4cf890401d3a1e09a
USE_GNOME= glib20
GNU_CONFIGURE= yes
PLIST_FILES= bin/mtpfs
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
.include <bsd.port.mk>