mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
With the release of 3.2.8 Ruby 3.2 series switched to security fix only phase and will be reach its EoL on March 2026. So change defult version of Ruby to 3.3. Following changes are made to pass exp-run. * Fix build of audio/rubygem-ruby-shout by adding '--with-cflags="-Wno-error=int-conversion"' to CONFIGURE_ARGS. * Build of devel/rubygem-mmap2 fails with Ruby 3.3 and later because of internal API change of Ruby. So mark BROKEN with them. * devel/rubygem-xdg7, sysutils/vagrant and www/redmine51 don't support Ruby 3.3 and later. So mark BROKEN with them. * misc/sdformat and textproc/ruby-rdtool are already marked BROKEN with Ruby 3.2 and build with all other Ruby versions also fails with same error. So mark just BROKEN. * Fix plist error of sysutils/puppet8. * Fix RUN_DEPENDS of textproc/quarto. PR: 286217 Approved by: self (with hat of ruby) Exp-run by: antoine
25 lines
525 B
Makefile
25 lines
525 B
Makefile
PORTNAME= mmap2
|
|
PORTVERSION= 2.2.9
|
|
PORTREVISION= 1
|
|
CATEGORIES= devel rubygems
|
|
MASTER_SITES= RG
|
|
|
|
MAINTAINER= mfechner@FreeBSD.org
|
|
COMMENT= Implement memory-mapped file objects for Ruby 2.x
|
|
WWW= https://gitlab.com/lyda/mmap
|
|
|
|
LICENSE= RUBY
|
|
|
|
USES= gem
|
|
|
|
.include <bsd.port.pre.mk>
|
|
|
|
.if ${RUBY_VER} >= 3.3
|
|
BROKEN= mmap.c:1108:24: error: no member named 'rmatch' in 'struct RMatch'
|
|
.endif
|
|
|
|
.if ${OPSYS} == FreeBSD
|
|
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
|
|
.endif
|
|
|
|
.include <bsd.port.post.mk>
|