mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.
21 lines
566 B
Makefile
21 lines
566 B
Makefile
PORTNAME= google-apis-compute_v1
|
|
PORTVERSION= 0.57.0
|
|
CATEGORIES= devel rubygems
|
|
MASTER_SITES= RG
|
|
PKGNAMESUFFIX= -gitlab
|
|
|
|
MAINTAINER= mfechner@FreeBSD.org
|
|
COMMENT= Simple REST client for Compute Engine API V1
|
|
WWW= https://github.com/googleapis/google-api-ruby-client/tree/main/generated/google-apis-compute_v1 \
|
|
https://github.com/googleapis/google-api-ruby-client
|
|
|
|
LICENSE= APACHE20
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
|
|
|
RUN_DEPENDS= rubygem-google-apis-core-gitlab>=0.9.1<2.0:devel/rubygem-google-apis-core-gitlab
|
|
|
|
USES= gem
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|