ports/devel/py-pytest-aiohttp/Makefile
Po-Chuan Hsieh ff87d64d94
devel/py-pytest-aiohttp: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
2024-05-13 21:59:40 +08:00

27 lines
897 B
Makefile

PORTNAME= pytest-aiohttp
PORTVERSION= 1.0.5
PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Pytest plugin for aiohttp support
WWW= https://github.com/aio-libs/pytest-aiohttp
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=51.0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=6.2:devel/py-setuptools-scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0.36:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.8.1:www/py-aiohttp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=6.1.0,1:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0.17.2:devel/py-pytest-asyncio@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
.include <bsd.port.mk>