mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
hatch-regex-commit provides a plugin for Hatch that automatically creates a Git commit and tag after version bumping.
23 lines
633 B
Makefile
23 lines
633 B
Makefile
PORTNAME= hatch-regex-commit
|
|
PORTVERSION= 0.0.3
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
DISTNAME= hatch_regex_commit-${PORTVERSION}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Hatch plugin to create a commit and tag when bumping version
|
|
WWW= https://pypi.org/project/hatch-regex-commit/
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|