mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
- Convert ports to use PY_TOMLI to simplify Makefile. The minimal version is set to 2.0.1 because it is required by multiple ports such as devel/py-poetry. The upper bound of version is set to 3 because it is limited by devel/py-poetry. With hat: python
24 lines
637 B
Makefile
24 lines
637 B
Makefile
PORTNAME= hatch-fancy-pypi-readme
|
|
PORTVERSION= 24.1.0
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
DISTNAME= hatch_fancy_pypi_readme-${PORTVERSION}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Fancy PyPI READMEs with Hatch
|
|
WWW= https://github.com/hynek/hatch-fancy-pypi-readme
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR} \
|
|
${PY_TOMLI}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|