ports/devel/py-hatch-fancy-pypi-readme/Makefile
Po-Chuan Hsieh 180cd7365c
Mk/Uses/python.mk: Introduce PY_TOMLI
- Convert ports to use PY_TOMLI to simplify Makefile.

The minimal version is set to 2.0.1 because it is required by multiple ports such as devel/py-poetry.
The upper bound of version is set to 3 because it is limited by devel/py-poetry.

With hat:	python
2024-07-22 00:55:40 +08:00

24 lines
637 B
Makefile

PORTNAME= hatch-fancy-pypi-readme
PORTVERSION= 24.1.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= hatch_fancy_pypi_readme-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fancy PyPI READMEs with Hatch
WWW= https://github.com/hynek/hatch-fancy-pypi-readme
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR} \
${PY_TOMLI}
USES= python
USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
.include <bsd.port.mk>