mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
Release changes: https://github.com/gptscript-ai/py-gptscript/releases/tag/v0.9.5 Reported by: "github-actions[bot]" <notifications@github.com>
34 lines
1.1 KiB
Makefile
34 lines
1.1 KiB
Makefile
PORTNAME= gptscript
|
|
DISTVERSIONPREFIX= v
|
|
DISTVERSION= 0.9.5
|
|
CATEGORIES= devel python
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= nivit@FreeBSD.org
|
|
COMMENT= Python module for running GPTScript
|
|
WWW= https://github.com/gptscript-ai/py-gptscript/
|
|
|
|
LICENSE= APACHE20
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=40.9.0:devel/py-setuptools@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=0.43.0:devel/py-wheel@${PY_FLAVOR}
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=2024.2.2:security/py-certifi@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}charset-normalizer>=3.3.2:textproc/py-charset-normalizer@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}httpx>=0.27.0:www/py-httpx@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}idna>=3.6:dns/py-idna@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}requests>=2.31.0:www/py-requests@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}tqdm>=4.66.2:misc/py-tqdm@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}urllib3>=2.2.1:net/py-urllib3@${PY_FLAVOR} \
|
|
gptscript:lang/gptscript
|
|
|
|
USES= python
|
|
USE_GITHUB= yes
|
|
|
|
GH_ACCOUNT= gptscript-ai
|
|
GH_PROJECT= py-gptscript
|
|
USE_PYTHON= autoplist pep517
|
|
|
|
NO_ARCH= yes
|
|
.include <bsd.port.mk>
|