ports/devel/py-geojson/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

31 lines
747 B
Makefile

PORTNAME= geojson
PORTVERSION= 3.2.0
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel geography python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python's Encoder/decoder for simple GIS features
WWW= https://pypi.org/project/geojson/
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.3.0:devel/py-nose@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>1.9:devel/py-simplejson@${PY_FLAVOR}
PORTDOCS= LICENSE.rst CHANGELOG.rst README.rst
USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>