mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
20 lines
439 B
Makefile
20 lines
439 B
Makefile
PORTNAME= fastcache
|
|
PORTVERSION= 1.1.0
|
|
PORTREVISION= 1
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= yuri@FreeBSD.org
|
|
COMMENT= C implementation of Python 3 functools.lru_cache
|
|
WWW= https://github.com/pbrady/fastcache
|
|
|
|
LICENSE= MIT
|
|
|
|
USES= python
|
|
USE_PYTHON= distutils autoplist
|
|
|
|
post-install:
|
|
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/fastcache/_lrucache*.so
|
|
|
|
.include <bsd.port.mk>
|