mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
24 lines
598 B
Makefile
24 lines
598 B
Makefile
PORTNAME= cloc
|
|
DISTVERSION= 0.2.5
|
|
PORTREVISION= 1
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= bofh@FreeBSD.org
|
|
COMMENT= Modern cli framework for simple and complex cli applications
|
|
WWW= https://github.com/tannerburns/cloc
|
|
|
|
LICENSE= MIT
|
|
# PYPI doesn't have a LICENSE file
|
|
#LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colored>=0:misc/py-colored@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|