ports/devel/py-azure-mgmt-datamigration/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

23 lines
676 B
Makefile

PORTNAME= azure-mgmt-datamigration
PORTVERSION= 10.0.0
PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= dbaio@FreeBSD.org
COMMENT= Microsoft Azure Data Migration Client Library for Python
WWW= https://pypi.org/project/azure-mgmt-datamigration/
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msrest>=0.6.21:net-mgmt/py-msrest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}azure-common>=1.1:www/py-azure-common@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}azure-core>=1.2.0<2.0.0:devel/py-azure-core@${PY_FLAVOR}
USES= azurepy python zip
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
.include <bsd.port.mk>