mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
23 lines
672 B
Makefile
23 lines
672 B
Makefile
PORTNAME= azure-mgmt-advisor
|
|
PORTVERSION= 9.0.0
|
|
PORTREVISION= 1
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= dbaio@FreeBSD.org
|
|
COMMENT= Microsoft Azure Advisor Client Client Library for Python
|
|
WWW= https://pypi.org/project/azure-mgmt-advisor/
|
|
|
|
LICENSE= MIT
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msrest>=0.5.0:net-mgmt/py-msrest@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}azure-common>=1.1:www/py-azure-common@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}azure-mgmt-core>=1.2.0<2.0.0:devel/py-azure-mgmt-core@${PY_FLAVOR}
|
|
|
|
USES= azurepy python zip
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|