mirror of
https://git.freebsd.org/ports.git
synced 2025-05-04 07:27:38 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
24 lines
654 B
Makefile
24 lines
654 B
Makefile
PORTNAME= azure-functions-devops-build
|
|
PORTVERSION= 0.0.22
|
|
PORTREVISION= 1
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= dbaio@FreeBSD.org
|
|
COMMENT= Azure Devops Build Manager For Azure Functions
|
|
WWW= https://pypi.org/project/azure-functions-devops-build/
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msrest>=0:net-mgmt/py-msrest@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}vsts>=0:devel/py-vsts@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|