mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
26 lines
660 B
Makefile
26 lines
660 B
Makefile
PORTNAME= PyExecJS
|
|
DISTVERSION= 1.5.1
|
|
PORTREVISION= 2
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= tcberner@FreeBSD.org
|
|
COMMENT= Run JavaScript code from Python
|
|
WWW= https://pypi.org/project/PyExecJS/
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist distutils
|
|
|
|
OPTIONS_GROUP= RUNTIME
|
|
OPTIONS_GROUP_RUNTIME= NODE SPIDERMONKEY
|
|
NODE_DESC= Use www/node as JavaScript backend
|
|
NODE_RUN_DEPENDS= node>=0.8.0:www/node
|
|
SPIDERMONKEY_DESC= Use lang/spidermonkey52 as JavaScript backend
|
|
SPIDERMONKEY_RUN_DEPENDS= js52:lang/spidermonkey52
|
|
OPTIONS_DEFAULT= NODE
|
|
|
|
.include <bsd.port.mk>
|