ports/devel/ocaml-ppx_blob/Makefile
2025-01-22 12:25:08 +01:00

46 lines
1.1 KiB
Makefile

PORTNAME= ppx_blob
DISTVERSION= 0.9.0
PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= ocaml-
MAINTAINER= freebsd@dev.thsi.be
COMMENT= PPX plugin to embed binary files in Objective Caml
WWW= https://github.com/johnwhitington/ppx_blob
LICENSE= PUBLIC_DOMAIN
LICENSE_NAME= ${LICENSE:S/_/ /}
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= ${SA_DIR}/ppxlib/META:devel/ocaml-ppxlib
RUN_DEPENDS= ${SA_DIR}/ppxlib/META:devel/ocaml-ppxlib
USES= ocaml:dune
USE_GITHUB= yes
GH_ACCOUNT= johnwhitington
DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
PORTDOCS= CHANGES.md LICENSE.txt README.md
OPTIONS_DEFINE= DOCS
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc
USE_BINUTILS= yes
.endif
post-patch:
@${REINPLACE_CMD} \
-e "s/(lang dune 1.11)/(lang dune 2.5)\n(version ${DISTVERSION})/" \
${WRKSRC}/dune-project
post-install:
@${STRIP_CMD} \
${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME}/ppx.exe \
${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME}/${PORTNAME}.cmxs
.include <bsd.port.mk>