ports/databases/py-PyGreSQL/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

28 lines
621 B
Makefile

PORTNAME= PyGreSQL
PORTVERSION= 6.0
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases python
MASTER_SITES= http://www.pygresql.org/files/ \
PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python interface to PostgreSQL, both classic and DP-API 2.0
WWW= http://www.pygresql.org/
LICENSE= PSFL
USES= pgsql python
USE_PYTHON= autoplist distutils
PORTDOCS= *
OPTIONS_DEFINE= DOCS
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pg/_pg*.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>