mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
PostgreSQL 17.5, 16.9, 15.13, 14.18, and 13.21 Released! The PostgreSQL Global Development Group has released an update to all supported versions of PostgreSQL, including 17.5, 16.9, 15.13, 14.18, and 13.21. This release fixes 1 security vulnerability and over 60 bugs reported over the last several months. Security: 78b8e808-2c45-11f0-9a65-6cc21735f730 Release notes: https://www.postgresql.org/about/news/postgresql-175-169-1513-1418-and-1321-released-3072/
24 lines
632 B
Makefile
24 lines
632 B
Makefile
PORTNAME= postgresql
|
|
PORTREVISION= 0
|
|
|
|
COMMENT= PostgreSQL database (client)
|
|
|
|
MASTERDIR= ${.CURDIR}/../postgresql14-server
|
|
|
|
BUILD_DIRS= config src/include src/interfaces src/port src/bin/pg_amcheck \
|
|
src/bin/pg_dump src/bin/psql src/bin/scripts src/bin/pg_config \
|
|
src/bin/pgbench doc src/makefiles src/test/regress
|
|
INSTALL_DIRS= ${BUILD_DIRS}
|
|
|
|
CLIENT_ONLY= yes
|
|
COMPONENT= -client
|
|
USE_LDCONFIG= yes
|
|
USES= pkgconfig
|
|
|
|
OPTIONS_DEFINE+=LIBEDIT DOCS
|
|
LIBEDIT_DESC= Use non-GPL libedit instead of readline
|
|
LIBEDIT_CONFIGURE_ON+=--with-libedit-preferred
|
|
LIBEDIT_USES= libedit
|
|
LIBEDIT_USES_OFF=readline
|
|
|
|
.include "${MASTERDIR}/Makefile"
|