ports/sysutils/syslinux/Makefile
Robert Clausecker 6e2da9672f filesystems: add new category for file systems and related utilities
The filesystems category houses file systems and file system utilities.
It is added mainly to turn the sysutils/fusefs-* pseudo-category into
a proper one, but is also useful for the sundry of other file systems
related ports found in the tree.

Ports that seem like they belong there are moved to the new category.
Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are
not moved as they currently don't fetch and don't have TIMESTAMP set
in their distinfo, but that is required to be able to push a rename
of the port by the pre-receive hook.

Approved by:	portmgr (rene)
Reviewed by:	mat
Pull Request:	https://github.com/freebsd/freebsd-ports/pull/302
PR:		281988
2024-11-06 16:17:35 +01:00

43 lines
1.1 KiB
Makefile

PORTNAME= syslinux
PORTVERSION= 6.03
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= KERNEL_ORG/linux/utils/boot/syslinux
MAINTAINER= beastieboy@beastieboy.net
COMMENT= Boot loader for the Linux operating system
WWW= https://www.syslinux.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= nasm:devel/nasm
RUN_DEPENDS= mtools:filesystems/mtools
USES= perl5 gmake tar:xz
USE_PERL5= build
MAKE_ARGS= CC="${CC}"
ALL_TARGET= bios
PLIST_FILES= bin/syslinux \
share/man/man1/syslinux.1.gz
PORTDATA= *
pre-patch:
@(cd ${WRKSRC}; \
${FIND} . -type f -exec ${GREP} -le 'elf_i386' \{\} \; | \
${XARGS} ${REINPLACE_CMD} -e 's/elf_i386/elf_i386_fbsd/g;' )
post-patch:
@${REINPLACE_CMD} -e \
's|^UMAKEDEPS|#UMAKEDEPS|' ${WRKSRC}/mk/syslinux.mk
do-install:
${STRIP_CMD} ${WRKSRC}/bios/mtools/syslinux
${INSTALL_PROGRAM} ${WRKSRC}/bios/mtools/syslinux ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/syslinux.1 ${STAGEDIR}${PREFIX}/share/man/man1
${FIND} -d ${WRKSRC} -type d -empty -delete
${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "bios efi32 efi64" ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>