ports/sysutils/py-python-crontab/Makefile
Charlie Li 06a08e69f3
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.

Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
2025-03-07 23:05:21 -05:00

29 lines
877 B
Makefile

PORTNAME= python-crontab
PORTVERSION= 2.4.0
PORTREVISION= 2
CATEGORIES= sysutils python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Read and write crontab files using a direct API
WWW= https://gitlab.com/doctormo/python-crontab
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-dateutil>=1.5:devel/py-python-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}croniter>0:sysutils/py-croniter@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cron-descriptor>0:sysutils/py-cron-descriptor@${PY_FLAVOR}
USES= python shebangfix
SHEBANG_FILES= ${WRKSRC}/tests/data/crontest
USE_PYTHON= autoplist distutils
USE_GITLAB= yes
GL_ACCOUNT= doctormo
GL_TAGNAME= ba23056ddf1a00ecfd14b0a31c2e0cdad132f8d0
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>