mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
- Resurrect fancy plugin for the GTK 3 version of Claws Mail. - Clean up dependencies. - Disable GDK deprecation warnings flooding the build log. - Enable i18n of the plugins. - Enable parallel build of plugins. PR: 275236 Approved by: Chris Hutchinson <portmaster@bsdforge.com> (maintainer)
19 lines
540 B
Makefile
19 lines
540 B
Makefile
PORTNAME= perl
|
|
|
|
COMMENT= Perl filtering plugin for Claws Mail
|
|
WWW= https://www.claws-mail.org/plugin.php?plugin=perl
|
|
|
|
USES= perl5 shebangfix
|
|
SHEBANG_FILES= src/plugins/perl/tools/matcherrc2perlfilter.pl
|
|
|
|
PLIST_FILES= share/claws-mail/matcherrc2perlfilter.pl
|
|
|
|
CLAWS_PLUGINS_BUILD= ${PORTNAME}
|
|
|
|
post-install:
|
|
@${MKDIR} ${STAGEDIR}${PREFIX}/share/claws-mail
|
|
${INSTALL_SCRIPT} ${WRKSRC}/src/plugins/perl/tools/matcherrc2perlfilter.pl \
|
|
${STAGEDIR}${PREFIX}/share/claws-mail
|
|
|
|
.include "../claws-mail/Makefile.claws"
|
|
.include <bsd.port.mk>
|