mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 10:06:40 -04:00
- Update version requirement of BUILD_DEPENDS py-setuptools should be used rather than PY_SETUPTOOLS
24 lines
725 B
Makefile
24 lines
725 B
Makefile
PORTNAME= lazy-object-proxy
|
|
PORTVERSION= 1.10.0
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Fast and thorough lazy object proxy
|
|
WWW= https://github.com/ionelmc/python-lazy-object-proxy
|
|
|
|
LICENSE= BSD2CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=8:devel/py-setuptools-scm@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
post-install:
|
|
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
|
|
|
.include <bsd.port.mk>
|