mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 07:41:50 -04:00
23 lines
612 B
Makefile
23 lines
612 B
Makefile
PORTNAME= setuptools-rust
|
|
PORTVERSION= 1.5.2
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Setuptools Rust extension plugin
|
|
WWW= https://github.com/PyO3/setuptools-rust
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}semantic-version>=2.8.2<3:devel/py-semantic-version@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4.3:devel/py-typing-extensions@${PY_FLAVOR} \
|
|
cargo:lang/rust
|
|
|
|
USES= python:3.7+
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|