mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 07:41:50 -04:00
21 lines
578 B
Makefile
21 lines
578 B
Makefile
PORTNAME= python-application
|
|
PORTVERSION= 2.8.0
|
|
CATEGORIES= devel python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Basic building blocks for python applications
|
|
WWW= https://github.com/AGProjects/python-application
|
|
|
|
LICENSE= LGPL21+
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR}
|
|
|
|
USES= python:3.6+
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|