ports/devel/py-jupyter-ydoc/Makefile
Po-Chuan Hsieh 6de44d4932
devel/py-jupyter-ydoc: Add py-jupyter-ydoc 0.2.3
jupyter_ydoc provides Ypy-based data structures for various documents used in
the Jupyter ecosystem. Built-in documents include:
- YBlob: a generic immutable binary document.
- YUnicode: a generic UTF8-encoded text document (YFile is an alias to
  YUnicode).
- YNotebook: a Jupyter notebook document.
2023-03-22 03:19:52 +08:00

30 lines
898 B
Makefile

PORTNAME= jupyter-ydoc
PORTVERSION= 0.2.3
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= jupyter_ydoc-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Document structures for collaborative editing using Ypy
WWW= https://github.com/jupyter-server/jupyter_ydoc
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-nodejs-version>=0:devel/py-hatch-nodejs-version@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}hatchling>=1.10.0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}y-py>=0.5.3<0.6.0:devel/py-y-py@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 31000
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
.include <bsd.port.post.mk>